Rackspace Webmail Access Issue

Incident Report for Cloudways

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 06:20 UTC

Investigating

Rackspace is currently facing issues with webmail login access resulting in unable to log in or use key features at this time. Their engineers are actively investigating the issue. More details will be posted as it becomes available.
Posted Dec 29, 2025 - 17:34 UTC
This incident affected: Add-on Services (Rackspace Email).